Weird episode of job running with no movement, and ignored lid-up

Had a strange episode on the 15th at 3:34pm EST with a starting a job normally and it just sat there with the fans running (no x-y movement - luckily no laser). Then I opened the lid to stop it and it ignored me and kept whirring away. I eventually just shut it down, rebooted and it all came back after a little while. I have since cut that job with no problem, but clearly if you look in the logs something happened?

Exact time stamp on that video (to correlate with logs): 9/15/2020 3:15:34pm EST

Hello @henryhbk,

Thank you for reaching out to us. I’m sorry you ran into some trouble with your Glowforge the other day.

I took a look at the logs for your unit and it looks like your Glowforge was having trouble maintaining a stable WIFI connection during the time you mentioned. The unstable WIFI connection caused your unit to have trouble calibrating.

The most common solution to Wi-Fi challenges is to restart all the devices involved in connecting to the internet.

  1. Turn off the computer, phone, or tablet that you’re using
  2. Turn off your Glowforge
  3. Unplug your modem
  4. Unplug your Wi-Fi access point
  5. Wait one minute, then plug everything back in and turn them back on

If that doesn’t work, we have two more suggestions that often make a big difference:

  1. Improve the signal path between your Glowforge and your Wi-Fi access point
    Wi-Fi signals need a clear path. Remove physical barriers, and move devices closer together:
  • Move your Wi-Fi access point up high and make sure it’s in an open space. Avoid locating your Wi-Fi access point on the ground, under a desk, in a cabinet, or in a corner where its signal can be blocked.
  • Relocate your Wi-Fi access point closer to your Glowforge
  • Move your Glowforge closer to your Wi-Fi access point
  • Install a Wi-Fi range extender closer to your Glowforge
  • Run an ethernet cable and install a second Wi-Fi access point next to your Glowforge
  1. Reduce electronic and Wi-Fi interference
    If your unit is near other devices that use Wi-Fi or a large number of electronics, temporarily turn off other electronics and devices in the area.

If the problem happens again, after trying the steps above, please let us know.

As I pointed out rebooting the Glowforge fixed the issues immediately. It seems (while certainly possible) given I have a state of the art mesh wifi, that it is improbable it was a signal path or strength issue (the rapsberry pi controlling my 3D printers sitting next to the glowforge certainly didn’t have an issue with wifi nor did the chrome box at the end of the table which was running the GFUI)

Signal Strength

I’ve extracted some data from the last few days of use in order to investigate further. In these logs we have a record of the average signal strength the Glowforge is capturing from the network it’s connected to. On average, this signal strength has been low over the last week, with average strength at around -69dBm as of today. For more context, on networks with very good signal strength, this will often run closer to -30dBm. A signal strength at -70dBm or lower would be very difficult to stay connected to.

That being said, I’d be happy to take a look at the logs from your unit. There may be something in there that helps explain the behavior you’ve been seeing.

Collect Unit Logs

  1. Hold down the button on your Glowforge for ten seconds, until it glows with a teal color

  2. Your Glowforge is now broadcasting a temporary Wi-Fi access point. Connect your computer to “Glowforge XXX-XXX” (from your Wi-Fi Settings)

  3. Visit the following URL in your browser:

  4. A .zip file should download to your computer

  5. Reconnect to your usual Wi-Fi network and email the .zip file to

Please let me know if you run into any difficulty with these steps.

Possible Power Supply Problem

If the problem isn’t explained by wireless trouble, or something in the logs, it is possible there is a problem with the power supply.

When the motors and the laser stop, but everything else continues, the power supply may need to be replaced. Rebooting may temporarily resolve the problem.

Weird. My wifi station reports excellent signal strength to the glowforge and my iPad sitting on the glowforge has full strength. And nothing has changed in months that I am aware of technically.

I will note the wifi on the glowforge is insanely slow to get to setup? It’s been 2 minutes. I’ve done this procedure like 20 times over the years… never more than a few secs. Can’t get much closer…

I just decided to not re-set it up… and back to the prior setup. I will email the logs…

Ok in the weirdness category (I included this in the email but just for all the usual folks to know what’s going on behind the scenes):

The really strange thing is I cannot find the Glowforge in my DHCP server’s logs. As in I assume it is on MY wifi, but I don’t see any evidence of that (the machine I thought was it doesn’t match the MAC address: (which I believe is 02:00:03:9b:fb:6e?) I don’t find the wifi SSID name in the main log so I can’t verify what network it is attached to (god I wish there was ethernet on this thing!) - or you could access this info in the gfui to debug stuff, I assume this isn’t doing something stupid like using my cellphone’s hot-spot or something…)

Or your neighbor’s wifi :slight_smile:

1 Like

A good a time as any to reference this story.


Thank you for working through those steps. I’m not able to locate the direct email you sent over that contained the log files, did you happen to utilize an alternate email to send them to us?

In regards to the Glowforge not showing up in your DHCP server’s logs, this is due to how your Glowforge connects during certain operations. Your Glowforge has two different network interfaces when it’s operating as a printer (during operation) and as an access point (during setup and when extracting logs). This is why the MAC Address you are seeing is not visible inside of the DHCP server logs. We can provide the correct mac address we see on our end when connecting to the servers via email if you would prefer.

After reviewing the details you’ve provided, I’m concerned that the mesh network configuration you’ve been utilizing could be causing the trouble you’ve been hitting. Mesh networks can experience trouble dropping 2.4GHz-only devices randomly under certain configurations or with certain firmware. Since you only experienced the trouble once, this is what may have cause the snag.

If you are still running into the same trouble, please let us know. If you have sent over the logs via an alternate email, we can still review them to see if any additional information can be obtained.

I did send it from a different email.

Thank you for updating us. I sincerely apologize for the delay. We’ve followed up directly via email with the next best steps, and also inquired about continuing troubleshooting on the Forum, or directly via email.

Please let me know if you did not receive this email, and we’ll send over the next best steps.

Yep, got the email. It’s been running perfectly since. So not sure what happened there, but whatever the glitch it went away. As I noted in the original post, it originally went away after a reboot, my biggest concern was that the lid interlock seems to have been affected by the same glitch. That should of course run locally not through a cloud service. On both my CNC machines the e-stop function is directly through the power supply, no software involved., you smack it and everything stops like you pulled the plug. I realize the Glowforge is a bit more nuanced, but still should run locally from a digital input on the control board to halt operation of everything network connectivity or no. On the Tormach the e-stop turns off power to all mill operations, but the controller is a separate PC physically inside but electrically outside the mill. So it just sees the thing at the end of the cable goes away, and goes into fault mode, while on the x-carve the e-stop button actually kills the power to the controller (in in my case since I modded the spindle and dust control to run off g-code it both are actively held on, so loss of power kills both.

1 Like

Thank you for updating us. I’m so glad to hear that everything appears to be working correctly, and you’re not running into the same behavior.

I apologize for the interlock errors you’ve been experiencing. I’ve extracted the log files from both of your units, and I’m not seeing any consistent errors pointing to an interlock problem. Your Plus and Basic unit’s do not have a standard interlock pin like the Glowforge Pro. Was there a specific time period where you notice this error occurring? I’d like to ensure everything is performing as it should.

OK so just to clarify, because I am guessing I’m not being clear. When the machine had the initial issue (which per your log analysis was a network disconnect) I tried to stop the job by lifting the lid (normal behavior). Not the interlock like the pro which is designed for opening your shop door when in unshielded operation mode so that someone doesn’t get home-lasik by your pro using the passthrough. The basic has always had a lid interlock (which is always happy to cause a mysterious fail when some wood chip prevents the lid from fully closing and the magnets aren’t engaged). So my concern was during the same incident that this whole discussion is about, the machine kept “running” [well clearly the fans were running, did not appear to be lasing] with the lid open. That may be either the machine was so confused it couldn’t run the safety check, or the safety check is done in the cloud (less safe - should be considered a bug). Now again, nothing appeared to happen, and being laser aware at that point I killed power, which obviously stopped it (I’m sure the pro has some zero-point quantum energy source but my basic at least can’t run without AC! so that stopped everything)


I’m so sorry for the confusion.

To Clarify

  • The lid interlock mechanism does take place locally, not in the cloud.

    For example: The mechanism works with or without a connection to the internet.

  • The lid interlock is designed to make sure the laser is not on, but does not affect the motors.

    For example: When you open the lid during a print, the laser stops immediately, but the motors still move the head back to home.

That being said, the manual (page 4) recommends using the power-cord:

  • In the event of any emergency or malfunction, unplug the power cord on the back of the unit.


  • The power cord is intended to serve as the disconnect device. Make sure the outlet is near the equipment and easily accessible, so you can unplug the unit if needed.

Wireless Still An Issue

A quick glance at the logs does indicate the wireless is still not stable. I see a long list of machine connections. I’m not sure if that is affecting performance, but I noticed and figured it may be helpful to mention it if you’re still troubleshooting that.

Crash Found

Also, I did find a crash dump in the logs you sent in. I’m looking into those now. I’ll follow up again when that investigation is complete although the results may or may not be very interesting.

1 Like

Laser is working fine since.

Thank you for updating us! I’m going to keep this thread open for a little longer, as my colleague @pip Pip is reviewing the logs you provided. We’ll send over more information as soon as it is available.

I’m so sorry for the delay, but I have a couple updates.

The crash dump that was in the logs, was actually quite old. The crash was back in February, for a problem that had been fixed in July.

The more recent incident, we’re continuing to investigate, but we have the details we need from the logs.

Glad to hear it.

I’m going to close this thread - if the problem reoccurs, go ahead and post a new topic. Thanks for letting us know about this!