Weird laser pattern on HD engrave


#1

I have a problem with a logo that tried to engrave. In the pic below you can see a weird pattern in the logo (circled in red) right down the horizontal middle of the design. If I use the same file and turn the logo to be facing up and down it engraves with no change in the pattern. Do you have any idea why this is happening?


#2

My educated guess would be that you are not using full power.

This means that the laser is pulsing at a high frequency. Because the top and bottom of the B is vertical as is the sides of the circle, the pulses are lining up. In the other situations the pulses do not line up and appear much more random.

To test this you can make a slight change to the speed to see if the pattern changes or goes away.


#3

Ok I when I etched the logo the 1st time it was using the built-in settings for HD Engrave (speed 300, power 16, LPI 450). I tried slowing the speed down to 275 and the pattern is better but, still not completely uniform. I guess I can just slow it down more to fix it. Seems weird that just changing the orientaion of the logo would make that weird pattern. I’ll just have to make sure I only engrave that logo facing up and down, and not to the side.


#4

Just yesterday there was another post with a issue with engraving across the center. Maybe just a coincidence. They said they could see anomaly in the preview for their file. Is there any difference in the preview between the rotated versions for you?


#5

I just loaded the file again and checked the preview, but I don’t see any difference in the on screen preview even after rotating the image.


#6

The band’s gone now (at least in the preview)! Unfortunately the ‘ugly’ regular dots at the top are still there… But I found the band to be the worst. Maybe it was just a temporary thing…


#7

Thanks for letting us know about this, and I’m so sorry your print didn’t turn out the way you expected.

So I can look into this further, I’d like to know whether you see the same results if you rotate the design before uploading it to the app. If possible, could you please try the following?

  1. Open the file in your design software of choice

  2. Using that program, rotate the design 90 degrees, as you did in the Glowforge app

  3. Save as a new Plain SVG file

  4. Upload that SVG to the Glowforge app and print using the same settings that produced the results you posted

  5. Reply to this thread with the time and date of the print

Thank you in advance.


#8

Ok I tried rotating the image and then saving the file, but the same thing happened again. The time and date of the print was around 10:30am 7/16/2018 today.


#9

What program are you using to manipulate that design? Inkscape? Illustrator? CorelDraw?


#10

I use Adobe Illustrator CC 2018.


#11

That is so odd. If you don’t mind sharing the AI file, I’d love to take a poke at it tonight and see if the same thing happens in an older version of AI. (You can send me a PM, I’m out for the bulk of the afternoon, but this is an interesting conundrum.)


#12

Ok I just tried saving the B logo into a new file by itself and the same thing happens with the weird pattern. Here is the Illustrator file if you want to try it.

B Test.ai (768.1 KB)


#13

Ahah! Looking at it I think I see part of the problem. It’s an engrave consisting of strokes (not fills), and that leaves you at the mercy of the GFUI interpretation. (They did a fine job of it by the way…the software interpreted correctly what you intended, but it’s usually better to tell them up front what you want them to do as far as engraving goes, by using subtracted fills to create your shapes to be engraved instead of strokes.)

Try using the file below on your material, rotate it if you like, and see if it creates the same issue with the funky patch.

B Test modified.zip (34.1 KB)


#14

Thanks for the help, but it’s still doing the same thing, with the new file you sent me. Here is the latest attempt.


#15

Got two more for you to test:

The first one is rotated in AI, bounding box reset, and saved as SVG.
Second one is rasterized in AI before saving.

Check those out too and see what happens…(it will help narrow the problem.)

B Test mod rasterized in AI.zip (26.3 KB)


#16

I just converted the original ai file to fills, and tested on wood at 275 lpi. I don’t see any weirdness.
450 lpi seems like overkill to me…


#17

@rsummers
Thanks for trying that and posting the result.

I’ll continue looking into this. I’ll update the topic when I have more information.


#18

Ok I tried both files and here are the results. The one on the left is the rasterized one.


#19

Yup…looks like there’s a bug somewhere in the vector treatment. :neutral_face:

For now, I’d recommend rasterizing your vector artwork for something like this that has islands inside of islands that you are planning to then rotate, because that’s the fail-safe treatment. (And the results actually look a little better I think…the engrave looks smoother to me.)


#20

Thanks again for taking the time to run those tests. We’re seeing this too, and the team is looking into it now. In the meantime, you can try rotating the artwork slightly, so that the lines inside the “B” are no longer vertical. This should help you get the best results for your intended settings.

I’m going to close this thread now; if you run into any other trouble please open a new topic or email us at support@glowforge.com. Thanks so much for letting us know about this!