White Screen when I press Select Material

Hi! I am getting a white screen and the site doesn’t load. I have loaded the image and see it fine. I can crop, adjust artwork, etc. As soon as I press “Select Material” the screen goes completely white and won’t load or do anything else. I have tried two different computers, two browsers - Edge and Chrome, and two different networks at work. Any advice???!!!


Use the set focus option - enter settings manually on the left hand side. set focus, click on material and print.

I’m having the same issue and it just started occuring today. I haven’t found a solution and have been stuck since I can’t select any material without getting to the white screen that never goes anywhere. The GF is certainly connected and updates the image of the material on the bed.
Hopefully someone figures out a fix soon.

1 Like

I’m having same problem!!

I am also having the same problem! I have rebooted my machine, my computer, reloaded the design, even tried a design I cut the other day. Nothing is working. When you click to set the material, I am re-routed to this URL → Glowforge - the 3D laser printer which leaves nothing but a blank screen.

1 Like

I just tried cutting some clock parts this morning and getting the exact same result as you. I ended up just using the Set Focus. Didnt solve the issue but at least I could do something.

same here.

same this morning. I just ended up using the Set Focus to let the machine determine thickness; then went on to enter my cut settings

I used that tip. Thank you. Like you said, it doesn’t fix the problem and THAT’S extremely frustrating.

1 Like

Same problem and I cannot manually enter material - actually I have never been able to. Tried Chrome and Safari. My phone and my computer.

same issue here and the camera isnt reading any proofgrade materials QR codes. I have tried different types of Proofgrade materials from wood to acrylic.
If someone would give me the proofgrade setting for the SD (not HD or Draft) I could continue with my project. I need setting for 1/8" MDF
Hopefully this is fixed soon
thanks so much

I’m having the same issue as well. Haven’t been able to print all day

1 Like

I am having the same issue this morning and I can’t figure it out!!!

I found on another posting here this webpage that is super helpful


Same here. Wondering if it is because I do not have Proofgrade material on the bed…?

not your issue its a Glowforge issue

1 Like

Mine has been doing the same thing all morning. I have cotacted qupport but have gotten nothing back.

This IS a GF issue, not user error.

Sadly, it’s just a reminder that because we use GF’s servers in the cloud, when they have a problem, everyone has a problem. :confused:

1 Like

I bought my GF from a friend, and she left a piece of Proofgrade Medium Basswood Hardwood with the QR code on it. I put it in the bed and the GF scans it and starts some movement. It says “ready” for print. I remove the QR code and it goes back to original issue. Hmmmmmmm. :frowning:

Is this a way for GF to force us to buy their materials???