With certain files i get stuck on rendering

I have been trying for a few hours to render one of my files. What is weird is this is not a new file, it is an older file that I’ve cut before (I need to open it to reference something).
I’ve also updated my google chrome so I do not know what the issue is

I literally am having the same problem. I made them just this morning but a couple hours ago all my files get stuck on rendering. I restarted, made sure everything was updated and walked away for a couple hours but it’s still getting stuck on rendering unless it’s a new blank design

So you understand my struggle :frowning:

If you are willing post your file here and someone else can see if it does the same for them (if you don’t want to post it to a public forum you can send it to support@glowforge.com and reference this open post).

If it opens for someone else, then the issue is with your software somewhere, if it doesn’t then it’s with the file.

Let us know!

P&S can only help one person per post so you should either open your own - or if you are also unwilling to post your art then you should instead send the email to support@glowforge.com.

It will never take more than a few minutes for a design to load - the most complicated ones are maybe 10, anything beyond that is stuck.

its definitely not complicated let me see if I can grab it

So I can’t get the one that I’m trying to reference but I’m also having issues with this new one… !
Agate essential oil holder 2|10x10

The file is most likely the issue causing the slow upload it has many many many nodes breaking the line into segments.

what program did you use to make this?

1 Like

Canvas :confused: I’ve literally never had issues before

I’m also having issue with other SVGs, that I’ve bought

If you purchased them it would be best not to post them to the forum as this is a public place.

oh well I’ll take it down then. But just saying its not working with bought Svgs… I don’t know what to do because I have a lot of customs I need to get done

Well looking at that last file there seems to be no issue there that i can see. I don’t know enough about canvas but someone else here might be able to help out with that. I use inkscape to design all my stuff and things.

I brought this file into inkscape and make the inner circles round and simplified he outside cut and joined all the stray sections together so it will be one cut and not 4 separate ones.

See if this will upload. the scale will probable be off from what you had.
thing 1.zip (2.5 KB)
thing 1

1 Like

I can’t upload it

Strange it uploads to my dashboard fine. i added a zip file to my last post.

sigh… what should I do? I’ve done a disk cleanup, updated my chrome, restarted my computer, let it sit… i’m going nuts.

You will have to wait for support staff I think. If you downloaded the file i posted and put that on the dashboard and its still not working i don’t know what else to do sry.

Sigh :frowning: I hope they help sooner than later, but seriously thank you for the help. I honestly am at a loss

While you are waiting, try a different browser. That might help you determine if the problem is browser related.


I believe the original file is too large for the bed, and it is located off of the artboard. (That can cause issues with loading.)

Create a new 20" x 12" art board or canvas, then copy and paste your design onto that new artboard. Make sure the design is the correct size there, then save the file for the Glowforge.

Always create a new 20" x 12" artboard and copy your purchased files into it. It eliminates sizing problems with the UI.

1 Like

tried it, it is still acting up