Error-Please Refresh your browser before printing

Hi, every time I upload a DXF file I get the following error:

I have tried refreshing my browser, clearing the cache, and restarting my glowforge and I keep getting this error. I have tried uploading DXF files that I have successfully used in the past and still get this error.


Hi, welcome. As this is your first post, are you a fairly new owner?
They said last year that DXF support would be a Premium only feature, so it would have worked in your two week trial period but if you didn’t purchase Premium after that it would no longer.

If that’s not the issue, try a different browser or device?

Hi, I have had the glowforge for several months now, and yes I pay for the premium features. This is not been an issue for me in the past. And yes I tried a different computer, same issue.

Although they did state they would support DXF, it is not a suitable file format for 2D design. I have dozens from 3D design days that do not work.

Try SVG or PDF.

Hi unfortunately this is a design from Fusion 360 and they do not support those file types as exports. When I tried converting to an SVG, it did not maintain the correct dimensions. Any suggestions on how to work around this, or generate an SVG that maintains the correct sizing?

Others here use Fusion so may know. I only use Fusion and DXF for 3D design, I use Inkscape (and years ago, Illustrator) for 2D.

Yeah they must have changed something about how they process the DXF files, because I’ve used hundreds from Fusion in the past several months without issue.

As much as I dislike when I ask for help with X and people say “use Y instead”, I’m going to be part of the problem :slight_smile: and suggest the Colorific post-processor as a better way to get your stuff out of F360.


Hi Chris, thanks for the rec. I actually ended up finding another plug-in that worked perfectly and made the SVG file: Fusion360 to Glowforge - #5 by ChrisCook8


I’m having this issue as well! AND I’m trying to upload existing DXF files that I’ve used without issue for about a year. Something is wrong…

I am also having the same issue with new and previously working dxf files. I suspect it is something broken on the back end. This is one of the big disadvantages of using a device that requires the cloud to work, and my biggest worry buying this device. This probably means I can’t use my GlowForge until they get back from the long weekend. Very frustrating.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.