HELP! I cant connect to wifi!

Hi there,
So Frustrated! I have spent the last two days trying to re-connect my gf to wifi.
I have gone through all the steps listed on the website as well as a few tips here in the forum. I have spoken to my internet provider and my internet is functioning normally. I have updated all my drivers and firmware. I have done everything! And still it will not connect.
Someone please help. I can’t get through to a human at GF.

Welcome to the forum.
Why are you required to reconnect? Did you change routers or providers?
How far in the setup do you get? Where does the setup fail?

I have no idea why it disconnected. No change in anything. It will not connect!

are u connecting to 2.4g or 5g?

have your connected your glowforge previously? do u see a teal button when your glowforge is on?


yes and yes

At what point does the connection fail?

everything works all the way through until i put in my password (WHICH IS CORRECT) and it goes right back to the get connected page.

Is the Glowforge button flashing teal?

not flashing but it is teal

Can you turn off wifi and try using your phone cellular hotspot connection instead?

tried that. it still wont connect

I hope support gets back to you. I have exhausted my experience library.

thank you for trying. i know, it really sucks!

Sounds like a browser issue on the device you are running the setup process from.

Try a different browser.

(the button should glow steady, not flash, so you’re good there - and if you’re connected to the temporary GF wifi to select your own network, all is good on the machine side.)

Ill Try That.

Tried a differant browser…

Such a bummer, I hope they get back to you soon. You’re going to have fun when it all gets connected so hang in there!

Did you try an older Tablet or Chromebook. I ask this because I’m not sure the Glowforge supports 5g and using an older tablet or phone or something that only has 2.4g may get you past this.

And another thing. I had another device I was trying to attach to my WiFi and for whatever reason, as soon as I used my wife’s iPhone, (I have an android) it worked.