Just got my glowforge on monday and now its not working, please help!

Hi everyone,

Im honestly getting really stressed and shaking about this issue and basically on the break on tears. Mostly due to the price of this machine. I recently just invested all my money in the pro to start a business ( got it this monday) and i just did a cut with some mirror acrylic with a thin piece of cardboard under and after the cut was done it was all burned and the cardboard was in a small amount of ashes. There was NO fire but the cardboard was hot. I cleaned everything up and nothing of the machine was burned but when i went back to start another cut my screen on the computer still showed the previous burned cut and its not changing or when i put another piece of material its not focusing or scanning. I also noticed that the lens on the lid has like scratch marks or something. But this morning while cutting it was making some loud noises. I dont know if the glowforge warranty will help with this. Please please please let me know what to do.

-Thank you


i have been playing on the computer and even when i add a new project its not working. it wont let me refresh the bed or anything and it says it keeps scanning. i have logged out and back in my still wont work. added completely new projects and still get the same screen

Take a breath, everything will work out. Turn the machine off and then back on. Close out the app. Refresh your browser and see what, if any, message you get. You did not burn your machine and it is not ruined.


thank you. i have turn it off the glowforge and turned it back on also closed out everything on my computer as well as cleared all the data. I just got back on the glowforge app and the screen is still on the same cut even when i pick a new project to start.

That means you don’t have a good WiFi connection - that screen will refresh when the :glowforge: can connect to the internet. I’d suggest shutting everything down - :glowforge:, router, modem, computer - restarting them one at a time starting at the wall and ending with the :glowforge: - wait until the first has completely rebooted and reconnected (usually ~1 minute plus) before going to the next one. If after everything is rebooted you still don’t have a good connection, then hold down the button until it turns teal and re-connecting your WiFi like you did when you first got the machine.


thank you.i have reset my internet and the glowforge but when i log into the design space my screen still shows my previous cut. the glowforge is also making a lot of noise so im not sure what is going one.

If it is making a lot of noise, it is probably doing the power on calibration sequence. It should stop after a little while.

If it keeps doing that, then there is a problem.

When you say “reset your internet and the glowforge” did you do all the steps out lined above?
When that didn’t work immediately did you then do the next step?
We don’t know what’s going on either - but by doing the troubleshooting steps and being clear about what you’ve done is the only way we’ll figure it out.

Eventually a staff member will be along, and if you’ve answered these questions up front they’ll be able to help you faster

yes i reset and unplugged all the router and modem plus restarted my computer and re set the glowfore with the internet. nothing is working. its still showing the same cut from before on the design space

Next thing: hold down your button until it turns teal and reset your WiFi like you did when you first got the machine, unless that’s what you meant by “re set the glowfore”

i did that about 3 times already. nothing is working. when it does reset it makes a lot of sounds like popping and the laser keeps moving to the middle but nothing is happening. im getting so frustrated with this and iv only has it for a few days :sob: :sob:

thank you for your help

When you run through the WiFi setup - does it say the WiFi is connected? (Do you get confetti on your computer screen?)

If yes then we’re probably at the time where waiting for a staffer to check your background logs is the right answer

If you want to continue troubleshooting I’d steer you to here next (you’ve already done section 1):

If nothing else, when a staffer does get here you’ll already have posted the photos so they won’t have to ask for them if they’d be useful.

yes. after reset i get the confettis. then it starts up and makes a bit of popping noise and keeps moving to the center. it just keeps moving around little by little with popping noise then stops like this

thank you. i really hope they will be able to check it soon.

Can you take a close up picture or two more of the camera in the lid? From a couple of angles. If that camera was damaged by the smoke, or not cleaned properly, it might be causing the trouble you’re seeing now.

1 Like

im not sure if you can see these but everythings looks to be okay. i even cleaned the lenses

IMG_1452|375x500 !

How do we fix that camera? i dont think there is a replacement for that on the site. would i have to purchase a whole new machine or will warranty help with this?

We don’t. They do. Which means a trip back to the mother ship.

It looks like there is a lot of grunge around the edges of the camera… I don’t know if that is scratches or glue or whether it is interfering with the camera image or not. That image has to be clear enough that the machine “sees” the Glowforge logo on top of the head, and it sounds like it might be getting stuck during the process.

They will be able to tell more from looking at the screen captures for your machine, and if there is an issue there, they will be able to let you know about it. For now, just wait to hear from them. You’ve tried everything you can do at the moment to get it running again.

1 Like

Thank you so much! Iv been so stressed today about this. Knowing that a super expensive machine isn’t working after a few days it’s really stressing me out. Not to mention having to stop things on my business. I hope they respond soon!!

When you get it working: never cut a stack of material. Putting things on top of each other is a recipe for fire, as you learned the hard way.

I’m not offering any more troubleshooting advice because you’ve got plenty. I think it’s just struggling with your WiFi.


Thank you. Yes I’m never doing that again. I’m just wondering why it’s a WiFi problem when everything else is working and that I have reset it multiple times. As well as unplug modem and router and reset computer.

It could certainly be something else, I just usually guess WiFi because it’s not updating the image and not finishing the homing process. Those things take a lot of network traffic, and the Glowforge seems to have weaker WiFi capabilities than a laptop or cell phone, so we’ve seen a lot of people with spotty connections, especially if the router is some distance away or not one of the modern extra juicy models.

Have you tried starting it up with the laser head already under the camera and with nothing on the bed? Sometimes stray lights in the room can also confuse it.

Yes I have tried without anything in the bed. It still does the same thing and on the computer still shows the last cut.