More image engrave issues

I’m still having issues establishing my work flow for my map engraves. I’m pretty sure at this point it’s an issue with the Glowforge UI. The main issue is I’m trying to set the position of my image in the SVG file I upload to the Glowforge. When I do this I’m getting artifacts that are not in the file. Slight blurring and letters are barely readable. In the past I would import the image separately and position on my cut file via the UI which gave great results but the image always comes in about 225%. So to get around that issue I’m working in photoshop at 300ppi and sizing my image to a workspace that is the same size as my cut file. I’ll edit the photo, grey scale, curves, levels, etc. I then bring it into illustrator and place the photo on my cut file exactly as I want, raster the image to the lines per inch I’ll engrave at and bring into Glowforge. That’s when I’ve noticed sometimes the image stars out darker for 1/4” before it fades to the correct amount. That’s like the laser isn’t warmed up so I’ve started doing small cuts first before I engrave which solved that issue but then I’m getting these small specs and not a clear image but if I soon on the Glowforge UI I don’t see them. I’ll upload a picture to describe what I mean.

This is on paper which engraved similar to leather.


I looks like you have a JPG image that isn’t pure white background and that it has a bunch of jpg artifacts that you’re not seeing but the machine is.

If you want to upload your source picture file I’m sure several people would take a look at it for you.


Well, I’m at work right now so not sure if I can upload the source. I might have selected transparent vs white background in illustrator when I rastorized. So that’s a bad choice? I should choose white?

You can download the file here:

White and transparent are the same, so long as it’s pure white. I’d agree that it looks like noise though.

What LPI are you using? Your source image should be around double the LPI, in my opinion.

1 Like

I have been trying 270 but I think that one was 225 to try and speed up the test. The starting file is 300ppi. My thoughts were not to try and go higher resolution than that to avoid errors. I’ve tried vectorizing to greyscale which helps some but adds some errors to the letters which I don’t like. I’m just puzzled. I don’t get why I can’t embed the image in the SVG without errors showing up.

I explicitly embed into SVGs rather than do them externally/add artwork.

Here is a test I ran a while back:

I’d have to suggest something in your process is going awry rather than a problem with the UI.

I’ll look at the file in a bit.

Looking at your file… where the noise came from, I can’t tell you, but there is a lot of it and that’s what you’re seeing engraved.

Anything less than 255, 255, 255 (which is pure white) will be engraved. Your background has a lot of stuff around 254, 253, etc.


Here’s what it looks like when I push the levels a bit to show the noise:


Exactly – the original sectional was compressed. To get a crisp, clean engrave it’s really important to use lossless bitmaps (png, bmp, tif, etc.) from start to finish. JPEGs are not your friend. :sunglasses:


Thanks everyone. I’ll try this again in the morning. Already the image looks better in PNG vs JPG. I’ll report back tomorrow

1 Like

I’m bashing my head in again. I’ve tried working with 600ppi and exporting the rastered image in 450 so I can engrave at 225. I’m still getting the fuzziness as described so I’m starting to think it’s something about my editing in photoshop. I’ll upload the original file I’m trying to engrave. Maybe you can take a look at it and give suggestions. I’m not sure how I can eliminate the low value greys that could be causing the issues. I’ve also included an upload of a wallet I made with the same file but as you can see it’s crisp and beautiful. I just cannot reproduce that again and I just don’t know why.

1 Like

I gotta take a break from this. I was carefully editing and looking closely at each step. It seems the curves are where the noise starts. I tried skipping the curves and levels and just engraving the image in greyscale. I had to bring the laser power way down and that seemed to cause the worst engrave like there just wasn’t enough power variations left to give the tone changes needed. I was at 25 on the power level. I then just brought the levels down to 170 max and that helped with laser power at 50 but still not that great so I went level 180 and power 75 and it seemed better but then I’m getting the noise again. I then tried 270 lines instead of 225 and same thing. I know this file isn’t the greatest for engraves and this part of the map is actually easier than other parts. I’ve printed salt lake city’s map and that was a bear with all the mountains the ground gets depicted as brown instead of green here at tampa. If this was the first time trying this I would probably just give up and move on but since I’ve had an excellent engrave on the wallet I use every day I know this glowforge can do what I want it to do. I can only get the clarity if I’m resizing inside the UI but that won’t work for my next project. I’m trying to engrave layers with the same map so that they line up and when I stack a layer with a cutout I want the layer behind it to have the same map and line up with the first layer. That’s when I ran into this issue. I just don’t get it. If I bring in the image from photoshop directly to the UI the image is the wrong size. If I bring the image into illustrator to embed it so the size is locked I get these issues. I’ll try again tomorrow night. This is beyond frustrating. My younger brother has a graphic arts degree and he too is stumped.

So, I think we are probably beyond the realm of Community Support, so this will probably be bumped over to Beyond the Manual

Either way, I’d say that you have your work cut out for you… it’s an incredibly detailed image without a ton of resolution, that already has noise present in the source file.

You can see that here:

Just my thoughts, but I’d probably look to do some noise filters (despeckle and reduce noise will help a fair amount) on the source image, and then do some level adjustments that clip the highlights. The tough part of the noise adjustments is making sure that the text isn’t impacted much… because the lines/letters are extremely fine.


You might also try Vector Magic or something (… the desktop version is pretty pricey though.

Feel free to move this thread. Live trace on illustrator gets close but dorks up the text too much. I’ll try your suggestion. Here is a picture of live trace as detailed as I can get it. If the image is small then most errors are hidden. I don’t know how to get illustrator to automatically clip the image to the size I want so I’m forced to do a lot of trial and error to get the live trace to line up right before I raster it again.

Try using a Black and White adjustment on the image in Photoshop instead of Grayscale. It gives you the option to selectively lighten or remove some of those background colors. They are all the same tone. (Results are gonna be muddy looking.)

There are only two colors in engraving, black (burned) and white (unburned.) Look at your image in that light to see how it’s going to turn out. (Shades of gray and colors are better for photos, not maps, and those are approximated using dithering.)

IMO, you’re asking a lot with the quality of the source image, without a lot of tedious clean up. Where is the original coming from? I noticed it was named as screenshot.

If this were on wood. I’d almost be inclined to try to mask it and use vari-power. Get the coloring/levels right and the masking would block the noise and peel right off. But with leather or paper, I don’t know that you would have enough range/fidelity in the power distribution to accomplish it.

1 Like

Thanks Jules. I’ll try that. I’ve been trying to figure a way to clip the extreme shades.

I’ve been using vary power. I don’t like the pixelated look from the vary dots setting. There is a very fine area of power that produces shades like 13%-22%. I ran a test with 100 squares all 1% from each other to see what was best. I just can’t figure how to compress the image into a range that falls within that tested range.