No Artwork in area- clearly shown that there is? SVGs and PNGs

I can only think of one other thing to try. It’s not clear which browser you are using, but can you try it with a different one? Chrome has been working well for me on the Mac.

I have seen that black fill quite often - it happens with GlowForge interprets a vector as an engrave instead of a cut/score for some reason. When I switch it to a cut or score, it then displays the vector properly, with no fill. I don’t know what causes GF to treat a vector as an engrave vs a cut/score, but it happens to me fairly often. Oddly, I can re-import the identical file multiple times, and sometimes a particular vector will be imported as an engrave and sometimes as a cut; I’m not too sure what rules GF applies to decide that.

4 Likes

I’ve seen the exact same thing, though only over the last week or so. I’ve also seen some cases where loading a known-good file produces nothing at all in the GFUI. Doing the browser dance and waving a dead chicken over the computer gets me going.

My SVGs are made in Illustrator and created with “Save As.”

Glowstaff, how about printing the software version and the browser software version somewhere in the GFUI? Or what about a link that pops up a detail panel with debug info like that? Even Apple lets you see software version numbers!

4 Likes

yeah I’m using Chrome.

I will give that a try, would love to do them as single files and not have to do all the lining up. Still learning, but this is puzzling because I’ve done it before.

I cannot replicate the “no artwork” problem using the files you supplied.

But that’s a little tricky, as I’m not working with the exact same elements as you are:
You said the flowers are a PNG, but the file uploaded example is a jpg. (Doubt it is as simple as that, but worth noting in terms of trouble shooting)

There is a line of text in your example photos, but is not present in the rectangle or the flowers files. Assuming it is a different file that was added with the “Add artwork” button, maybe that file has a guide line in it somewhere (in which case it would throw an error if you try to move it around the bed), or an element off of the artboard? Use select-all (command-A on a mac) in the GFUI to see if there are any outliers (the blue bounding box would extend off the screen in that case)

1 Like

It might be an intermittent bug in how the interface is interpreting the files, but I can’t figure out why some people are seeing it and not other people.

That causes me to think it has to be something in how the files are being saved, exported or created - but there are a lot of variables out there to mess with.

If the next time you save a file you could take a screen cap of the settings on the SVG popup, I’d be interested in taking a look at it.

Something wonky happening somewhere.

I think I am embedding…

and the cut line is just a red stroke… no fill

here’s the file
RomanceCollectionTextureforGF.svg.zip (3.1 MB)

Seems like I’ve heard that you should uncheck “responsive” in that save dialog.

3 Likes

Ahhhh…Uncheck Responsive. Set up your SVG settings like this one:

AI settings new to save as SVG drea

(just beat me @cynd11) :wink:

2 Likes

Decimal Places defaults to 1, at least it did on my fresh install, so check that too.

1 Like

If you are designing in inches or cm, use Decimal Places: 3.
If you are designing in px, use Decimal Places: 1.

4 Likes

now it is worse, can’t even see the floral pngs. I have dumped my cache, tried a different browser, saved the file again, uploaded again… selected “all” to make sure there are no guides, cleared guides and made the artboard the same size as the artwork before saving, I am at a total loss.

04 AM

Certainly not the cause of your symptoms, but just an FYI: if you change CSS Properties to Presentation Attributes, then SVGs you upload to the forum here won’t lose all their style information. (they will still lose any embedded images, unfortunately)

Crazy question, but these are crazy times: do you have an ad blocker in Chrome? Or, for that matter, any sort of content-altering plugins? If so, it might be worth trying it with all of them disabled.

I noticed some weird problems on my own machine when I was blocking some of the tracking and analytics they embed in the site.

2 Likes

I had the same problem, shapes that I cut the day before with no problem, showed up black and I got the “no artwork” message.

Also the founders ruler from the store showed up black with the same message.

I turned off the Glowforge, deleted all the cookies in my browser, and restarted everything… and now the files load normal again.

I can’t replicate the problem, but it didn’t have anything to do with the files, since I cut them before and I got the same error with the store items…

1 Like

I’m so sorry you’re still having trouble with your design.

I see you already posted about this and I’m working on it there, so I’m going to close this topic.