SVG File Not Correctly Sorting Elements

Hi, Just got my Glow forge today and noticed when I export a SVG file from Illustrator with one layer as the cut and the other as the etch, certain elements are being considered cut when they are on the etch layer. Any leads?

Layers aren’t the way to go, the file gets interpreted based on Fill and Stroke colors. There’s a tutorial here that explains how to set up your files for printing.

And another good one here

8 Likes

Thanks! I’ll read through and see where I’m going wrong. Currently I’m exporting from Illustrator to a SVG.

1 Like

In simple terms, if you make everything you want to cut red, and everything you want to engrave black, when you upload to the GF UI, you should have two groups of items, and can set the appropriate process for each. If you want to score some paths, you use another color for that.

Many times you many want to perform different cut and engrave processes in particular order, so you can use more colors, and then arrange those in the UI by dragging each step on the left as appropriate.

1 Like

Thanks! I really mean it. That made a huge difference, though there is still this phantom layer that is still the cutout plus circles that are meant to engrave.

1 Like

Make sure that you don’t have a stroke and a fill defined for the object. Always either or to default to correct operation.

1 Like

You can skip the SVG business and copy/paste straight from Illustrator to the GF dashboard page if you like (using keyboard ctrl+c/ctrl+v) :smiley: Its a real time saver, especially when testing and prototyping.

3 Likes

Current versions of Illustrator only though…doesn’t work for us CS folk. :anguished:

:confused::slightly_frowning_face::slightly_frowning_face:

1 Like

Also these topics are critical.

2 Likes

That is a time saver, but for some reason it still divides it into multiple layers.

Killer tip… I gotta try this

1 Like

Each of the operations on the left-hand-side is a different color in the source file (or different bitmaps.) The glowforge separates your file into different operations first by whether it is an engrave or a cut. Each bitmap (and by bitmap I mean a graphics file like jpg, png, bmp, etc…) is its own engrave operation. Each fill color is its own engrave operation. Then it breaks out the fill engraves and cuts by color. So a black line and a red line are separate cut operations and a blue fill and a green fill are separate engrave operations. A black fill engrave and a black cut are separate operations (because first separated by engrave vs. fill.)

2 Likes

Can you share your source file (.ai)?

Thanks! I’ve been messing around and notice that elements from the same layer are being processed separately. Any recommendations on what I can do to have it interpret just a cut layer and etch layer?

Sure, I’d love to have someone look at it. I’ve noticed now in recent cuts, overlapping shapes are not being cut for some reason. GhostVector_1.ai (330.3 KB)

The GFUI doesn’t do layers, it does raster objects and colors.

Overlapping parts are known to cause the GF to skip those…

Looking at your file…

1 Like

Your file appears to have several objects with both fill and stroke, meaning they are both defined. That means they overlap. I use inkscape, when I turn off fill on your design, these are the remaining strokes/paths:

(I do not see layers, I assume Inkscape is collapsing them all down to one layer)

You need to remove the stroke from objects you want to engrave (leaving fill), and delete the duplicates/overlapping paths. That should take care of it…

(here’s what the UI sees when I save your file back out of Inkscape)

2 Likes

Awesome, thanks for taking a look. I think with a few design tweaks I should be good to go.

1 Like