Blurry engrave

I’m having problems with engraving. The image it’s engraving is blurry vs the artwork, it happened after a cleaning, i thought it was a fluke because it only engraved part of the image messed up and then it was fine. Well it did it again, so I recleaned it and made sure to put everything back correctly and it worked fine for a little while but then messed up again, so I turned it off and restarted it for calibration, it worked fine again, but just now messed up again. It’s ruined 3 cutting boards now. This has also been accompanied by it being significantly off-about an inch one way, and then after a cleaning 1/4" the opposite way, and again back the other way. The first Buffalo is how it is suppose to look, and the other what it engraved.

Some of that effect might be the type of wood you are engraving on, but the wobbly text doesn’t look right at all.

And I have no idea what could cause that effect…looks like its skipping steps. Did you check to make sure when you reconnected the ribbon cable after cleaning that the pins were seating correctly and that one of them didn’t get bent or broken? Is it unfolding correctly in the channel? (No twists in the ribbon, just the one fold at the right?) Ribbon isn’t loose?

That’s a puzzle.


That looks a lot like what my first one started doing… :frowning: It printed fine over most of the bed, but anything that took it into the rightmost side of the bed made it start messing up.

Before we get too “gloom and doom,” though, check this post for suggestions to make sure nothing’s messing with your gantry alignment: Gantry Alignment Issue

If all that checks out, then I’m guessing support is going to want you to print a “gift of good measure” on PG draftboard, one in the middle of the bed and one as far as you can get it to the right. Take screenshots of each in the bed after printing, and also photos of how each of them turn out.

Good luck!


The strange thing is it engraves fine intermittently. The lettering on the bear was done immediately after engraving the bear. I didn’t even open the glowforge in between. What could have changed?

Both buffalo are actually the same wood. I’ve engraved probably 100 of this board, it’s not the wood. On one of them it engraved the first half fine, and then got blurry.

And there’s absolutely nothing stuck on the tracks? No little bits of wood or masking…particularly about halfway up the bear, depending on where it was placed? You checked the wheels too…nothing stuck under one?

If it changed in the middle of an engrave, I’d look for something that caused it to happen physically…maybe it hit something. But you probably need to hear from support.

1 Like

Well there’s the mechanical aspect with the gantry, but also mirrors for the laser and positioning. Perhaps after all that engraving, some of the soot/debris got onto the mirrors or lens causing the distortion (shift) of the beam?

1 Like

So I did a vigorous cleaning and this piece came out of the lens. Not sure if it was broken, or if this is how it’s shaped normally, but it came out and I didn’t want to risk trying to fix it.

This post looks like it deals with a similar problem:

1 Like

Yeah, that looks like the magnet ring that comes on the blue lens removal tool - they are very fragile and tend to crack. (Neodiddliums do that.)

Make sure the lens isn’t scratched, but you can pick up a spare removal tool in the Glowforge shop. (I just picked up a spare with another order.)

You can still go ahead and install the lens - the installation side doesn’t use the magnet.

Or glue that one back on the tool. I think it only fits on the removal end. Crazy glue to the rescue.


I’m not sure this was from the removal tool I think it was sitting on top of the rubber gasket in the lens. Here’s the removal tool. It still has the magnet piece on it.

Looking at your image and at an image from the topic I linked to it seems that this is the snap ring that holds the washer in place that holds the lens in place. If this seems right to you then you might want to gently put the snap ring back in place. Or just wait for GF support.


I went to clean the lens and see if it would fit back in, and the glass piece fell out of the metal. :slight_smile: So I think I will wait for my replacement one, not looking to burn the house down or anything.

1 Like

Yep, this is it.

1 Like

Oooh, yep. That might have had an impact on the engrave too. Good catch @AhnoldZ. :grinning:


We need to thank @scott.wiederhold for the great images he created.




(Just one of the many words I’ve adopted/stolen from the clever folks here…you’ll pick up a bunch too.) :smile:


Oh no! Thanks for letting us know about this, and for providing all the details and photos about what you’ve tried and what happened. I’m so sorry for the trouble. A new printer head lens should be able to resolve the issues you’ve been seeing. We’ll be happy to send you a replacement lens. I’ll follow up by email shortly to sort out the details.

Last but not least, thanks a ton to everyone for their help in this thread!