Laser does not find center (upon startup/centering)

I have the same problem as postet here:

At startup the GF starts centering after short “focusing”. But it seems it can’t find the center.
It moves the head somewhere near the center, but then starts moving in little steps further to the left/front. But never back.

  • I tried several tricks like start the machine with lid open, then after a while close it.
  • Wifi should be no problem - I have a repeater connected by cable standing in the room.
  • Logo on the Head is clean
  • lenses are clean.

Also the image of the bed doesn’t refresh.

thanks in advance.

1 Like

Image of the bed doesn’t refresh until after the full and successful calibration.

1 Like

Thanks for letting us know about this, Mitch. The issues you’re seeing might be caused by a poor connection with the cables on your lid. If you haven’t yet done so, please follow the steps below to check the lid connections:

  1. Turn off your unit.
  2. Open the lid.
  3. Using both hands, gently roll the laser arm to the front of the unit.
  4. There are 5 clips pictured below. Check each one to ensure it is closed. The clip should lie flat, and you shouldn’t be able to flip it in any direction.
  5. If any of the clips are open, ensure the cable is inserted straight into the clip and close the clip.
  6. If any of the cables are misaligned in the clip, take a photo of the clip and cable and send it to me so I can take a look before you proceed. Do not try to adjust or reseat the cable.
  7. Close the lid.
  8. Turn your unit back on and wait for it to calibrate.

Let me know how it goes.

wish i got a responce like this instead of just being told it would need to be replaced, nobody even remotly tried to trouble shoot this issue for me.

dont hold your breath leadscreamer, its probabaly going to need to be replaced as thats what they said to me. wierd that mine does the incremental little step bit but instead of to the left it goes to the right.

They can often tell from your logs if there’s a problem that can’t be fixed on the user end. There’s no point in trying to do any troubleshooting when they already know there’s a hardware issue, it would just cause you to have to wait even longer for your replacement!


At the moment im going to have to wait an awefully long time since they refused to cover the cost of shipping a new one out to me and the cost of shipping the current broken model back to them.
Im overseas and the cost of frieght each way is $1000.

Ouch. :frowning:


us unternational cutomers get the pointy end of the stick it seems -_-
my machine is only 3 months old too.

Hi vee,
I’ve checken all 5 connections. One clip was open. I closed it, now everything is in place. Still not working.

@rmmurphy223: oft course I’ve meant to the right side.

Hopefully this video loads, if you watch it to the end you will see my issue is the fact that on startup it “centres” into the cutting bed edges. If I have the lid closed and turn it on it outright doesn’t do anything. If I do the leave the lid open trick and shut it after it does the initial startup clicks and fan spool this is what happens.

1 Like

@leadscreamer Unfortunately, it looks like your unit is experiencing an issue that we can’t resolve remotely. I want you to have a reliable unit, so I’m recommending we replace this one. I’ll be in touch via email to sort out the details. I’m so sorry about the bad news.

@rmmurphy223 I see you already emailed us about this and we’re working on it there.