Stepper motors not synchronous + grinding noise

Hi,
I just got my GF Pro today :heart_eyes:
After following the instruction and getting the machine ready for the print (impressive by the way), it was time to test the laser.

Unfortunately it was disappointing as a first run, I didn’t expect to have a problem with it in my first day :cry:
I want to cry… :’(

image

I did want to print a hexagone but the head didn’t follow the path correctly.
I noticed that after the start and the calibration, when the head support (laser bed) tries to move, the Y1 and Y2 steppers are not synchronized, which makes a grinding noise and led to chaotic movement.

Can you please help me with this issue.
Since am at Paris, it will be a wallet breaking to send it back…
Thank you in advance,
Regards,
Badr

Update: similar issues -----------
Y-axis sticking/jumping, then crash
Sticking stepper motor?
Laser Carriage Skewed
Stepper motor lag, choppy cut lines

First thing to do is check that all the belts are tight and properly seated. Then check that everything moves properly - with the power off, you should be able to gently move the head from side to side and the gantry or laser arm front to back. If it will not move smoothly for its entire travel in either direction, you have the starting point of your issue. If everything moves smoothly and you have ensured there is nothing in the movement system, like a stray piece of packing, a rubber washer, or something else, you will need to wait for support to get back to you.

Note that by opening this topic you have also opened a ticket with support; they have said that emailing them also will slow down the response since they have to resolve two requests now instead of just one. If you don’t feel like you get a response soon enough, you may want to use the chat function before emailing them.

2 Likes

Thank you for your recommandations.
Actually everything moves properly when the motors are not powered, but when the motors are powered the right one Y2 (or left Y1) makes resistance to the momvent.
I will check later today if it comes from the motor itself or from to pulley or other.

What I did just now, I completely removed the belt of the right motor Y2:

And things work as expected:

I know it isn’t the best configuration, I will not use it with a belt messing for my productions, I will continue checking to point the right cause.

I hope to get support from GlowForge, this kind of issue is a major one, I can’t use the machine (for my first day) due to a basic CNC synchronisation problem that I can’t sove myself right now.

I was expecting that the machine at least was passing mechanical quality tests before shipping… :disappointed_relieved:

Any idea how other solved this issue?

Per your other post, they do test the machines before they are shipped. If your machine is under warranty it will be solved by GF.

I suspect that the stepper cable has been dislodged during shipping or the stepper itself failed at the end of testing or the driver has been damaged. If you have already cleared the stepper and belt I suspect you will have to wait on support.

2 Likes

It’s really frustrating when all the excitement to have it and use it turn down the first day of use :’(

1 Like

Totally understand that. Just know that GF will solve it. They don’t make a practice of shipping defective units and every unit is tested before it leaves, so this was not something they did through lack of diligence or care. You just happened to be the unfortunate recipient of a machine that was likely damaged during transit.

1 Like

That is a real buzzkill. I would check the integrity of the stepper connection.
For what it is worth, I have had a machine over two years now and it’s a workhorse.
Good Luck!

I am so sorry to hear about the trouble with your first print. I have replied to your email with your next steps. So I am going to close this thread.