Vent svg

i recently posted about my window vent and someone asked if i was willing to share the design. i figured i’d set it here in case anyone else could get some use out of it too :slight_smile:

here is the svg. set up for 1/8" thick. not adjusted for kerf.

vent.svg.zip (9.4 KB)

vent.ai.zip (1.0 MB)

when i cut it out for myself i ended up cutting a few extra circles so the hose had more to grab on to.

(update 7.24: fixed the corrupted svg file. above download should be good to use).

99 Likes

@MackadooWackadoo - here you go! hope this helps :slight_smile:

1 Like

Great share! Lot of folks will be looking for something to use. :grinning:

1 Like

Tried downloading it twice, but when I unzipped it the SVG is corrupted. Windows 10 64bit using Illustrator to open.

It opened in Inkscape, but even after I saved the file again, it wont open in Illustrator.

Thank you for the file.

i get an error on pretty much all of my svg’s out of illustrator (idky) - but even though they show an error on my computer they still work in the gfui. (if anyone can tell me why i get that error or how to fix you’d be my savior).

i added a .ai file to the original post - hopefully that’ll work for folks if the .svg doesn’t.

:slight_smile:

We’ve got a write-up on the correct settings to use when you save your files:

5 Likes

Nice design! Thanks for sharing!

1 Like

@Jules - thanks for the link. i read through it and tried a few things but still get the same error…

What kind of error, and which version of Illustrator are you using? Not sure if I can find anything, but if you want to Zip it and then upload one of the problem files someone might be able to figure out what’s going on with it.

Inkscape showed incorrect dimensions for objects in this file although the GFUI seemed to reproduce correctly.

Issue seemed to be that the original program (Illustrator, apparently) used 72 DPI and Inkscape uses 96 DPI.

The following topic describes a similar problem. A comment from Chris1 early in the thread helped me resolve the anomaly. It required text editing the SVG file.

1 Like

@jules - i get the above error (with different line and column #'s depending on the file). i have illustrator cs6.
i haven’t had any problems with it opening in the gfui so i have just ignored it so far. (the files attached to this post are the original .ai plus the .svg that has the error, if anyone wants to take a look.)

@alan.moerdyk - thanks for the link. i read through it and it is probably helpful to someone (i didn’t understand a lot of it), but i don’t use inkscape so i’m not sure a lot of it applied to me (please correct me if i’m wrong about that).

@aubreybuller Thank you!!! Was this here the whole time? Facepalm.

You’re using the Mac version, right? I was able to open the AI file in my older version of CS5, but couldn’t open the SVG in Illustrator.

(And the AI file came over with a ton of clipping masks, which always happens when I try to open newer versions of the AI files in the older AI program.)

Looks like they are compensating for it in the Glowforge interface though, so it can be used as is…you’re only going to have trouble with people with older versions of AI who want to try to make modifications to it.

I can’t quite say why, but there is some AI info that is causing the error. Mayhaps you have a plug-in, or defined something unique somewhere… some coder-type person might be able to notice what… the error mentions cutDepth, I don’t know where that would or would not be defined in AI.
Anyhoo,
I opened the AI file, didn’t see anything too weird (except for white fills on all objects, but that’s a different matter, makes no difference in terms of these errors). I stripped the white fills out anyway, and changed the colors just in case that was a thing… it wasn’t.

Then I saved it as an EPS and brought it back into AI, then se-saved as an SVG again. Same issue.

Then I saved it as a PDF, with “Preserve Illustrator Editing” turned off. I brought that back into AI, saved as an SVG, and got a file with no (apparent) errors in the Mac OS. Brought that to the GFUI and it threw a clipping path warning.
Opening this version in AI showed me that a clipping path had been added to each element, so I used Select All and then Object>Clipping Mask>Release.
I saved that version as an SVG, and got no errors from Mac OS or from the GFUI.

Maybe @scottmillersb or someone else running Windows can try it again to see if it throws an error/corrupted file

vent_AI_pdf_svg-Unclipped

(@Jules I did not see any clipping masks in the original AI file when opening it in CC2018)

I wish I could tell you what is actually causing the error.

4 Likes

Oh, that’s because I’m opening it in CS5…always happens. (Real PITA.) :neutral_face:

(You boys with the current versions of the software really ought to be doing all the troubleshooting…I’m just behind the times with this one.)

1 Like

The offending line(s) in the SVG is:

<path shaper:cutDepth="0.2500" shaper:pathType="exterior"

Are you using some kind of plugin for the Shaper Origin? Those are custom SVG commands that are meant for the Shaper Origin to read… kind of like how Inkscape uses Inkscape-specific commands in SVG files (for Inkscape-SVG’s vs Plain SVGs).

Or placing an SVG into the illustrator file perhaps?

2 Likes

wow - thank you all for doing so much work looking in to this!

@jbv - i just tried the save as pdf and then resave as svg - that worked for me too. if i need to, that is a more than acceptable workaround for me! thanks :slight_smile: also the fills are there because that’s my working file - i find it easier to select objects that have fills, but i change all that once i’m getting it ready to print. i guess i could have done that before sharing!

@jbmanning5 - i didn’t think about it until your reply, but i am importing these shapes from SketchUp - that’s probably what is attaching those weird parameters! i’m going to continue to do so (i haven’t gotten the hang of fusion) but at least i have a work around now for it :slight_smile:

(@MackadooWackadoo - no worries - this was uploaded after you asked. i thought it would be easier to share here)

2 Likes

If that works, that works. I would try and figure out exactly what is in enabled/installed in SketchUp that is trying to specify a cut depth.

Perhaps this plugin?

https://extensions.sketchup.com/en/content/svg-face-export-compatible-shaper-origin

2 Likes

Very generous of you to share—thank you!