Simple pendant engrave error

I am trying to make a simple pendant. There are only 3 vector groups. The outside (cut), hole (cut) and the inside (engrave). When I tell it to engrave it engraves over the letters even though the letters are a part of (the same color in corel) as the inside octagon: (2.2 KB)

What am I doing wrong?

I simplified the paths and then changed the stroke to path. It should engrave the letters and the inner octagon. I can’t test since i won’t have my replacement until tomorrow… maybe someone else can chime in @Jules


What software did you use?

First off, Glowforge ignores vector line thickness. If you think the thickness of the vector lines will be engraved, you are mistaken.

Your outside “engrave” that encircles the pendant will be like a thin score. The inside monogram will have the same issue, and there are at least two paths for that one.

I didn’t expect the vector lines to be engraved at all. I see the vectors as start/stop points for the engrave. So it should engrave up to the edge of the monogram and then stop. I don’t know what’s going on here. This is a simple export from Corel Draw. I’ve been using it for all sorts of vector applications since about 1996. First time I’ve had this issue. I am uploading here a simpler test. Just two circles, one inside the other. I want to engrave the outer circle and leave the inner circle alone. They are part of the same group. (764 Bytes)

Yes, to what has been said above…I expanded your stroke to turn it into an engrave, if you want it to appear that thick.

Here’s the trick with designing for the Glowforge - for vectors, anything you want to be Engraved should have a Fill but no Stroke color. Anything you want to Cut or Score should have a Stroke (Outline) color but no Fill color.

So with that in mind…tell me if the photo above is the way you want it to look when it’s done. By expanding the stroke, it does not completely fill in the letters, but leaves a nice little highlight in there that you might not mind. (2.9 KB)

(And there’s a little overview tutorial here that might explain a lot about how the Glowforge interprets designs:


I got excited there. I tried fill and no stroke for the two circles and it still failed. This is what it should look like:


Unfortunately, there is a known issue with how the GF interprets CorelDraw created SVG files that deals with the winding rules…the current work around is to either save the file as a PDF or rasterize the results of your vector drawing before saving the SVG file.

Another thing to take into account is that the white filled area in the center has to be subtracted from the blue filled area…the GFUI treats any vector fill color, even white fill, as something to be engraved.

There’s another mini-tutorial for dealing with vectors that explains it here:

Actually, at 600 ppi, the Glowforge handles raster engraves just as well as vector engraves, and you get more options for it…I tend to just recommend rasterizing the engrave portion of the design these days…it tends to be quicker.

1 Like

Sometimes :slightly_smiling_face: 95% of the time it appears to choose the method the GF handles. It’s the other 5% that’s problematic.

It likely has something to do with the order the objects are drawn or whether the Boolean operation is foreground minus background object or vice versa. I never bothered to test the variables as it doesn’t happen often enough to make it worth the time

Most often people forget the Boolean or don’t know to do it and just lay one shape on top of the other expecting to see a blank piece.


I didn’t realize that…I thought it happened all the time. So it’s mostly just a forgetting to subtract thing?

Well, shoot! :neutral_face:

No. It happens after you subtract. But it’s not easily replicated. It’s some obscure combination of steps that causes the fail. What’s worse is because it’s a valid SVG operation opening it in Inkscape & resaving it won’t make it safe so the GF deals with it.

But most times people blame the winding rule error for Corel files it’s because they didn’t do the subtraction in the first place :slightly_smiling_face:


I ran into the same problem using Corel. Below is how I figured out how to make Corel work for the GF.


This is how I would approach what I think you intend.

  1. The outer most shape should be filled.

  2. Make the inner monogram into a jointed filled object.

  3. Subtract / punch out the monogram from the larger shape to create a construct with a background area around the monogram to be engraved and the rest ignored.

Excellent. I remember reading that in the spring but promptly continued to draw this GS in random order :grin:

BTW, you use the Weld tool in your post. Have you tried the other booleans (simplify, subtract) and does it behave the same?

Yeah that’s a much better way to explain the problem to a Corel user…thanks for the reminder! :grinning:

Only if you cut the monogram out of the engrave shape. If you put a white circle on top of a black circle, it looks like a donut to us, but to the GF it looks like a black circle to engrave, and then a white circle to engrave on top of it. You have to actually cut the white circle out of the black circle so that it IS a donut, to get a donut from the Glowforge.

1 Like

Yes, it should work the same. Just remember if you’re creating an island fill to follow the even/odd pathway before you merge the curves.

Just, please don’t divide by 0. (though this is a real place in California)


What is that? Salt dome collapse? :smile:


It’s this place.