Stuck Centering/Focusing: How to Troubleshoot for potential Lid Cable issues before contacting Support 😲

Although “Stuck in Centering/Focusing” looks the same to the customers, it can be caused by a bunch of different things, and it’s easier for Glowforge to analyze it individually by looking at the machine logs than it is for us to do it. That’s why they don’t post solutions here. It can make things worse if the customers get the wrong “cause” and start trying to fix it without knowing what’s causing it.

If you want to start running through a process of elimination to eliminate other causes while you wait to hear from them, it will greatly speed up the resolution of the problem for both them and you, and I highly recommend it for the quickest resolution. When you have completed each test below, turn the machine on, and try a quick test print to see if it’s working again. :slightly_smiling_face:

First thing to check and eliminate is Wifi issues.
(A dropped signal will commonly cause the screen to lock up, but it’s pretty easy to clear.)

  • Turn off the machine. Turn off the computer. Unplug the router.
  • Wait a couple minutes.
  • Plug the router back in and let it fully start up.
  • Turn on the computer and let it fully start up.
  • Turn on the Glowforge and let it complete the startup calibration.
  • Then open the and check the status for “Ready”.
  • Try a print of the Gift of Good Measure on the sheet of draftboard that they sent with the machine for testing purposes, to see if it’s working again. (Or any small print that has a score, an engrave and a cut.)
  • If it’s still locked up, wait a couple hours and try again. Your internet service provider might be having issues somewhere along the line. (No other way to tell if it’s a service provider issue.)
  • Set up a WiFi hotspot on your phone and connect your Glowforge to it; this will rule out for sure whether it’s a WiFi issue.

Second thing to check for is visibility issues.

  • Make sure the lid camera lens is clean. (Use a Zeiss wipe to clean it if needed.)
  • Make sure the Glowforge logo on top of the head is clean and clearly visible.
  • Make sure there is no glare on the machine from a sunny window or bright overhead light.
  • Dark materials on the bed can prevent the laser from taking the Auto-focus reading. Use a light colored masking on dark or shiny materials.

Third thing to check is cable connections.

  • Turn off the unit.
  • Carefully remove the printer head by pulling gently up and back to disengage the magnets and remove it. Remove Printer Head Instructions
  • Check the connection on the white ribbon cable in the laser arm. Make sure it is fully inserted into the printer head, until it has clicked into place and that the pins are in good shape.
  • Check all of the ribbon cable connections in the lid. The connectors need to be fully closed.
  1. Turn off your unit.
  2. Open the lid.
  3. Using both hands, gently roll the laser arm to the front of the unit.
  4. There are 5 clips pictured below. Check each one to ensure it is closed. The clip should lie flat, and you shouldn’t be able to flip it in any direction. Check that the cable is not kinked or bent where it passes over the metal lip at the green arrow shown.


  • There has been a recent outbreak of issues related to a problem with how a ribbon cable was installed on a batch of machines, and repeatedly opening the lid all the way upright (90°) can cause wear on it and break the wires inside prematurely. That can be replaced, but you’re going to need to hear from support for that…I think they can look at the logs to see it, and they’ll get you a new cable with email instructions on how to change it, which should eliminate the problem.
  1. If any of the clips are open, ensure the cable is inserted straight into the clip and close the clip.
  2. If any of the cables are misaligned in the clip, take a photo of the clip and cable and send it to Support before you proceed.

Do NOT try to adjust or reseat the cable without the okay from Support.
You can :fire: the electronics.

  1. If all the clips are aligned and closed…close the lid.
  2. Turn your unit back on and wait for it to calibrate.

That’s all that you can test for up front. If the machine is still not functioning, you will need to contact support, tell them which tests you have run, and what the results were. (Be specific, using this list, and it will prevent them having to ask you about whether you conducted the tests or not, which can add additional time to the process.) Cable replacement is going to take from several days to a week (at a minimum), so you might need to give a head’s up to any of your customers that there could be a delay. But check the other issues that you can first…it might be one of those, and then you can get back to lasering. :slightly_smiling_face:

Stuck on Centering , Centering, Centering
Glowforge Stuck on Centering after setup - JUST came back from repair!
Scanning and nothing else
Received my refurbished unit
Start button does nothing. Its flashing blue and when I push it, nothing happens
Stuck on centering, focusing, helllppp
Stuck on "Centering" During Power Up
Glowforge Pro stuck on centering
Glowforge Pro, Bought in May. Huge issues
Old faithful is stuck on centering
Help! Glowforge plus isn't working, head doesnt center!
Stuck on homing/centering for 12 hours
Glowforge is stuck!
Glowforge is stuck!
I need help with how to keep my Glowforge connected to the internet
"Unable to complete print error" and button is orange
Oh no! Stuck on centering
When I turn the machine on it doesn’t do anything
Machine Stuck in centering mode. Please help!
Yellow/Orange Light - Please help
Help my glowforge button is orange/Amber
My glowforge is stuck on scanning or centering
2nd issue with orange button
Stuck on scanning/centering/focus with no movement
Calibration not starting
GF Stuck on Focusing
Machine not working properly
Centering - Homing - Focusing - Off Line
Frozen calibrating and head not moving
GLowForge stuck on Focusing
I am stuck in centering/homing
GF Plus turned off after a print and won't turn on
Ghost wood and stuck on focusing
Stuck on centering or focus
Stuck on centering or focus
Laser not firing - everything else seems okay
Software stuck "scanning"
Just in scanning mode with materials
Auto focus is taking too long
Stuck at Scanning
Stuck on centering and focusing
GF stuck on "SCANNING"
Blurry camera, spots on lenses, and stuck on scanning
Blurry camera, spots on lenses, and stuck on scanning
Connected to wifi, but won't connect to the server
BRAND NEW GF stuck on Focusing and gantry not moving
My GF is stuck focusing after 1-2 jobs
Insert text (Premium) has been spinning all morning even after reboot--all other tools work fine
Orange button :(
Nothing like finally getting your Glow Forge and IT NOT WORK
Newbie here help
Glowforge stuck in centering
Stuck on focusing barely used plus out of warranty march 21
Stuck on 'centering', with yellow button
Stuck on centering EVERY TIME!
Stuck in Focusing
HELP! won't stop cancelling
Bed image won't update. It stays in
Stuck on Scanning mode
Scanning, Centering, no movement
Stuck in "Scanning..."
Glowforge stuck in “Scanning”
Glowforge stuck in “Scanning”
"Lid Open" error when trying to print, but lid is closed
Problems with continual centering
Focusing, focusing, focusing
Glowforge head is getting stuck
One print per day then it gets stuck on focus
Glowforge Basic stuck on "Centering"
Glowforge Stuck on "Centering"/"Scanning"
The centering problem has finally hit me
Laser Not firing - tests have been done, no luck
Stuck on Focusing Head
Two issues no power and head won’t move
Not working won't center
Stuck on Centering after cleaning unit
Just got my glowforge on monday and now its not working, please help!
Glow forge stuck on centering
Glowforge lasertube/arm not moving smoothy
Stuck "Centering the head of your glowforge"
Lid open errorrr
Interface hangs, Glowforge will not cut
Stuck focusing on power up, not sure why
Stuck on Scanning/Centering
Stuck on Scanning 2020 edition
Image from glowforge camera not updated
Printer head not moving and stuck centering
Emergency- help....machine Reads scanning /homing
Stuck focusing when powering on
Stuck on "Centering", "Scanning", and "Focusing"
Stuck on centering, arm not moving
Please help...going to lose my marbles!
GF stuck counting down
Stuck in a scanning
Glowforge is stuck on centering during first project
Glowforge stuck on centering!
Laser is not printing
Lid Open tho lid is closed
Problems with the machine
PLEASE HELP! Laser not firing at all
Stuck on 'Scanning'
Glowforge laser not firing
Stuck in Centering/Scanning
HELP! stuck on centering/focusing
Stuck on centering part 2
Glowforge is DEAD (resolved - just a WiFi PW issue)
Dreaded Lid Open
Brand new out of the box-stuck on centering!
GF Keeps saying Scanning,Centering
Black Cable Hack for Voiding Warranty
Machine not calibrating after multiple attempts stuck on "scanning"
The death orange light
Printer Carriage will not move/ Stuck on Scanning/Centering
Stuck on "Scanning" when turning machine on
It shows as"LID OPEN" when it actually closed as usuall
Carriage and laserhead not moving, stuck centering
GF Printer head will not move
Anyone else having issues today? Mine is stuck in "Centering"
Stuck on centering, focusing, helllppp
Going to need black cable
Suddenly stuck on centering and/or scanning
HELP ! my machine is stuck on scanning
Head will not move and says centering
Suddenly stuck on centering and/or scanning
Anyone else having problems? Stuck in Centering?
Is there anyone else experiencing scanning mode and machine is not working?
Stuck at scanning stage
Stuck on focusing... again
Scanning, Scanning, Scanning
Stuck on "focusing" Saturday, now stuck on "Centering"
Help! Lid Open error
Glowforge will not read
Machine Stuck on Scanning and Head won't Move - Again
Glowforge stuck on "Centering" and "Scanning"
Help please Glow Forge is stuck on centering, scanning and focusing
Help please Glow Forge is stuck on centering, scanning and focusing
Glowforge will not complete calibration
Stuck on Homing, centering,
Laser Head not moving
Glowforge Plus is stuck on centering/focussing
Problems turning my GF on
Offline, centering, offline

Excellent writeup, @Jules! Incredibly comprehensive.


Well…after you’ve walked a few dozen folks through it…it tends to stick. :rofl:


Have only had it stuck on centering a couple of times and turning machine off, put the laser under the lid camera so it can find itself again, has solved it every time. I was not aware there were so many other ways to check!


Depends on what caused the issue. When mine has locked up (less than a handful of times) over the last 3 years, moving the head underneath the lid camera didn’t always fix it, and as a matter of fact, lately it has caused the head to crash into the front of the machine during the startup calibration. Rebooting everything clears the decks completely, so I cut straight to that step. (It’s the nuclear option.) :smile:


Good thinking! I know you have wayyyyy more experience!

1 Like

Don’t know about that, but I do hate crashing the head into the front, so i try to avoid the restart with the head under the camera. (It’s too scary!) :ghost:

What a great resource this is! Thanks Jules!


One more thing to add: Dark/shiny material on the bed. You can try sticking some masking over it in the area where the machine is focusing, to help it focus.


Good! Added! :slightly_smiling_face: :+1:

One of the biggest indicators that isn’t often mentioned is whether the head is moving at all or not. Very often the head will be lost and just hunting around (either strong light making weird shadows or holes in the material, or a dirty logo on the head). The status will stay on centering because it’s trying to center / but it’s very different than getting zero motion from the head.


Good point. We probably need to get into the habit of asking that specifically. Sometimes they mention it, most times they don’t.

1 Like

I think the post title needs updating. This has gone 'way beyond just troubleshooting for lid cable issues. :wink: Including “focusing” in the title might make it easier to find for people having that issue, too.

True, actually it’s a good general all around troubleshooting guide that I follow on an ongoing basis. :smile:

1 Like

I also think there is a lack of understanding regarding the level of communication between the machine and the server. Because their laptop or whatever connects to the WiFi, it is easy to assume that nothing is wrong with the connection.

We turn the machine on and the bed is imaged, that is uploaded. The server interprets the image and sends motion commands to the machine, which executes the command. The bed is imaged again, and uploaded. This back and forth communication continues until the server is happy with its understanding of the head position, the 3 axis have responded and calibration is achieved.
All it takes for the calibration routine to go sideways is a dropped packet or two.
I don’t think the integrity of the Wi-Fi network can be judged from the simple connection of a laptop.
I think the hotspot connection is a good test to help in troubleshooting the WiFi integrity.


re: WiFi issues. I’ve written this before but will again. For some reason my Glowforge and my Apple TV (similar to a Roku), just do not get along. They are on the same table as it is the only option. If I forget and do not unplug my Apple TV before attempting to print, I will get all kinds of errors, ‘offline’, continuous centering, etc.

So just because you think you have a good WiFi connection, have rebooted, etc, your connection could still be intermittent due to a variety of factors and needs to be better.


Yes! WiFi interference is another potential issue.

Here is a potential fix for “stuck on focus”. At least it worked for me:

I just completed a fairly large project so I decided to give the machine a good cleaning, following the method recommended by GF and used the fan maintenance utility. Didn’t use the GF after. This morning when I started it up, no usual startup routine. No centering, no movement at all. Went from “Offline” to “focusing” & stayed there. I tried all the usual stuff, checking cables, restarting router, different browser, checked cables. Still no luck. Then It occurred to me that I hadn’t heard the usual “clicking” at startup during focusing. So I removed the head (again, I had already checked the lens) but this time I gently pushed the lens out of its resting position, just slightly further into the head. When I powered everything up - it worked! Not sure if the lens was stuck, but this did the trick.


It was most likely the re-seating of the head on the carriage plate, which corrected a bad connection. That’s one of the troubleshooting steps that shows up now and then, and should probably be on the list above.


Put it in there. It’s a Wiki. :wink:

1 Like